Scirra Construct Fr
Vous souhaitez réagir à ce message ? Créez un compte en quelques clics ou connectez-vous pour continuer.

Scirra Construct Fr

Un logiciel open-source créateur de jeu en DirectX d'un simple glisser-déposer en toute simplicité.
 
AccueilPortailRechercherS'enregistrerConnexionScirraForum Scirra

 

 Problème avec l'objet AVI

Aller en bas 
AuteurMessage
nuparu1997



Messages : 7
Date d'inscription : 10/10/2010

Problème avec l'objet AVI Empty
MessageSujet: Problème avec l'objet AVI   Problème avec l'objet AVI Icon_minitimeDim 10 Oct 2010 - 16:48


Bon, j'ai récemment utilisé l'objet AVI pour mettre une cinématique au format wmv dans mon jeu,
j'ai mis les évenements comme ça :

Problème avec l'objet AVI Problmep

La cinématique défile nickel (elle dure 23 seocndes), et quand il faut passer au layout suivant, je vois seulement le bouton qui est présent dans le layout d'après, mais le reste de l'écran est noir et je ne peux rien faire.

Quelqu'un sait-il ce qu'il faut faire ??
Revenir en haut Aller en bas
squale
Admin
squale

Messages : 21
Date d'inscription : 10/10/2010
Age : 40
Localisation : strasbourg

Problème avec l'objet AVI Empty
MessageSujet: Re: Problème avec l'objet AVI   Problème avec l'objet AVI Icon_minitimeDim 10 Oct 2010 - 21:06

Je crois malheureusement que ce que tu vois c'est le player de ta vidéo, je viens de faire le test, il reste présent d'un layout à l'autre. D'après le site officiel, la prise en charge des vidéos est une fonction qui est encore au stade de développement, elle est encore buggée.
Revenir en haut Aller en bas
http://www.pascalsengler.fr
nuparu1997



Messages : 7
Date d'inscription : 10/10/2010

Problème avec l'objet AVI Empty
MessageSujet: Re: Problème avec l'objet AVI   Problème avec l'objet AVI Icon_minitimeLun 11 Oct 2010 - 14:21

Ah mince j'avais pensé à ça cela me semblait assez problable que cela soit le problème.
Bon, je vais chercher une alternative à l'AVI !
Revenir en haut Aller en bas
Doo89



Messages : 15
Date d'inscription : 23/08/2009

Problème avec l'objet AVI Empty
MessageSujet: Re: Problème avec l'objet AVI   Problème avec l'objet AVI Icon_minitimeMar 12 Oct 2010 - 11:33

Tu as essayé avec un layout intermédiaire, qui serait vide et passerait directement sur ton layout?[list][*]


Dernière édition par Doo89 le Mar 12 Oct 2010 - 16:44, édité 1 fois
Revenir en haut Aller en bas
nuparu1997



Messages : 7
Date d'inscription : 10/10/2010

Problème avec l'objet AVI Empty
MessageSujet: Re: Problème avec l'objet AVI   Problème avec l'objet AVI Icon_minitimeMar 12 Oct 2010 - 16:17

comment ça ? Je ne comprends pas ce que tu veux dire, peux-tu expliquer plus en détail ?
Revenir en haut Aller en bas
Doo89



Messages : 15
Date d'inscription : 23/08/2009

Problème avec l'objet AVI Empty
MessageSujet: Re: Problème avec l'objet AVI   Problème avec l'objet AVI Icon_minitimeMar 12 Oct 2010 - 16:43

Je n'ai pas encore testé, mais l'idée serait de créer entre ta page ou tu as ta vidéo et ta page ou il y a ton bouton plus le reste, une autre page vide qui dés quelle est chargée passe à la page suivante (bouton + reste).

Ou si comme el dit squale, le lecteur rete d'un layout(page) a l'autre, c'est mort comme solution.
Revenir en haut Aller en bas
Doo89



Messages : 15
Date d'inscription : 23/08/2009

Problème avec l'objet AVI Empty
MessageSujet: Re: Problème avec l'objet AVI   Problème avec l'objet AVI Icon_minitimeMar 12 Oct 2010 - 17:03

Bon je viens de tester en vain, même résultat!

Rien n'y fait, j'ai essayé de modifier la position de AVI en script, ou un destroy, mais rien!
J'ai voulu tricher avec le plugin Layout sur lequel je peux faire un destroy mais encore rien!
Revenir en haut Aller en bas
nuparu1997



Messages : 7
Date d'inscription : 10/10/2010

Problème avec l'objet AVI Empty
MessageSujet: Re: Problème avec l'objet AVI   Problème avec l'objet AVI Icon_minitimeMar 12 Oct 2010 - 17:04

Ah d'accord non j'ai déja essayé ca marche pas Crying or Very sad
C'est énervant quand même !
Revenir en haut Aller en bas
Doo89



Messages : 15
Date d'inscription : 23/08/2009

Problème avec l'objet AVI Empty
MessageSujet: Re: Problème avec l'objet AVI   Problème avec l'objet AVI Icon_minitimeMar 12 Oct 2010 - 17:19

Et si tu créer ta vidéo dans un petit programme à part qui se refermes dans elle est finie!

Dans ton programme d'origine tu appel ton programme vidéo qui se lance en premier plan, et quand c'est fini tu te retrouve dans ton programme.
Revenir en haut Aller en bas
squale
Admin
squale

Messages : 21
Date d'inscription : 10/10/2010
Age : 40
Localisation : strasbourg

Problème avec l'objet AVI Empty
MessageSujet: Re: Problème avec l'objet AVI   Problème avec l'objet AVI Icon_minitimeMar 12 Oct 2010 - 22:56

Pas bête, ca doit surement marcher. bounce
Revenir en haut Aller en bas
http://www.pascalsengler.fr
nuparu1997



Messages : 7
Date d'inscription : 10/10/2010

Problème avec l'objet AVI Empty
MessageSujet: Re: Problème avec l'objet AVI   Problème avec l'objet AVI Icon_minitimeJeu 14 Oct 2010 - 17:06

Euh d'accord je veux bien essayer mais je sais pas comment il faut faire.
Revenir en haut Aller en bas
Doo89



Messages : 15
Date d'inscription : 23/08/2009

Problème avec l'objet AVI Empty
MessageSujet: Re: Problème avec l'objet AVI   Problème avec l'objet AVI Icon_minitimeJeu 14 Oct 2010 - 18:28

Alors dans ton jeu tu mets le code:
Problème avec l'objet AVI Dansle10
Quand tu cliques sur le bouton construct lance le programme 'cinematique01.exe'



et dans une autre création avec construct tu fais le fichier executable 'cinematique01.exe' avec dedans:
Problème avec l'objet AVI Cinema10


Tu peux une fois ton fichier cinematique01.exe créé l'intégrer directement dans ton jeux:
Problème avec l'objet AVI Exedan10
Cliques droit sur Files et AddFiles
Revenir en haut Aller en bas
nuparu1997



Messages : 7
Date d'inscription : 10/10/2010

Problème avec l'objet AVI Empty
MessageSujet: Re: Problème avec l'objet AVI   Problème avec l'objet AVI Icon_minitimeVen 15 Oct 2010 - 16:31

Merci ça marche inpec !
C'est une très bonne idée que tu as eu, et ca marche !
Vraiment Meerci ! Very Happy Very Happy Very Happy
Revenir en haut Aller en bas
Contenu sponsorisé




Problème avec l'objet AVI Empty
MessageSujet: Re: Problème avec l'objet AVI   Problème avec l'objet AVI Icon_minitime

Revenir en haut Aller en bas
 
Problème avec l'objet AVI
Revenir en haut 
Page 1 sur 1

Permission de ce forum:Vous ne pouvez pas répondre aux sujets dans ce forum
Scirra Construct Fr :: Entreaide :: Constrct entre membre-
Sauter vers: